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Abstract:  

Hyperboloid solar concentrators, hinging on hyperbolic geometry, are pivotal in harnessing the 

power of sunlight. Their defining characteristic is a hyperboloid shape, which enables the 

precise focus of incoming solar rays onto a designated focal point. These concentrators, 

classified into primary and secondary types, hold immense promise for numerous solar energy 

applications. Primary hyperboloid concentrators are designed to directly channel sunlight onto 

specific targets like solar cells, making efficient use of their hyperbolic shape for concentrated 

light collection. Complementing these, secondary hyperboloid concentrators work in tandem 

to further amplify solar radiation concentration, often finding applications in concentrated solar 

power (CSP) systems to elevate concentration ratios. 

 

Ray tracing, a computational technique, plays a pivotal role in the design and optimization of 

these solar concentrators. By simulating how sunlight interacts with the concentrator's surfaces 

and its subsequent redirection to the target, ray tracing elucidates the intricacies of light 

collection and concentration. Employing specialized software tools like Zemax and TracePro, 

engineers leverage ray tracing to analyze and optimize concentrator designs. It facilitates the 

establishment of critical parameters during the initial design phase, allowing the precise 

visualization of how the concentrator's shape, dimensions, and material properties affect 

sunlight concentration. 

 

These simulations contribute to crucial performance metrics, including optical efficiency, 

concentration ratio, and irradiance distribution, offering quantitative insights into the 

effectiveness of concentrator designs. Further, sensitivity analysis, made possible by ray 

tracing, is employed to gauge how minute design parameter variations can influence 

concentrator performance, aiding in fine-tuning and optimization. 
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The future of solar concentrators lies in advanced materials, manufacturing techniques, and 

emerging technologies. Ray tracing remains integral in evaluating these advancements, 

ensuring that hyperboloid concentrators continue to shape the forefront of renewable energy 

technology. In a world increasingly reliant on sustainable energy sources, these concentrators 

represent an innovative and promising solution, underpinned by the meticulous analysis and 

optimization enabled by ray tracing simulations. 

 

  

Keywords: Renewable Energy, Solar Concentrator, Zemax, Trace PRO, Ray tracing 

simulation 

 

 

1. INTRODUCTION 

 

1.1. Hyperboloid Solar Concentrators: 

Hyperboloid solar concentrators harness the principles of hyperbolic geometry to efficiently 

capture and direct sunlight to a specific point. Their key feature is the hyperboloid shape, a 

three-dimensional surface formed by revolving a hyperbola around its axis. This shape is 

instrumental in focusing incoming sunlight onto a focal point. The hyperbolic geometry ensures 

that parallel rays of sunlight are accurately directed toward this focal point, resulting in the 

concentration of solar energy. This capacity to intensify sunlight is advantageous for various 

solar energy applications. 

The hyperboloid geometry has unique optical properties. The cross-section of a hyperboloid is 

characterized by two branches, and each branch plays a distinct role in light concentration. One 

branch converges incoming parallel rays to the focal point, while the other diverts divergent 

rays away from the focal point. This behavior enables the concentrator to capture and 

concentrate sunlight efficiently. [1-2] 

 

1.2 Types of Hyperboloid Concentrators: 

 

There are two primary types of hyperboloid concentrators: 

 

Primary Hyperboloid Concentrators: Primary hyperboloid concentrators are designed to 

directly focus sunlight onto a specific target. They achieve this through their hyperbolic shape, 

which efficiently concentrates incoming light onto the focal point. The geometry and focal 

length of primary concentrators are critical factors in determining the concentration ratio and 

optical efficiency. These concentrators are often used in concentrated photovoltaic (CPV) 

systems, where they direct sunlight onto high-efficiency solar cells. 

The performance of primary hyperboloid concentrators can vary based on their specific design 

parameters. For instance, a primary hyperboloid concentrator with a focal length of 1 meter 

can concentrate sunlight to an intensity over 1000 times greater than direct sunlight. This 

concentration factor significantly enhances the energy output of solar cells and can lead to 

highly efficient energy conversion. 
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Secondary Hyperboloid Concentrators: Secondary hyperboloid concentrators are 

complementary to primary concentrators. They work in tandem with primary concentrators to 

further enhance the concentration of incoming solar radiation. Secondary concentrators are 

positioned at the focal point of primary concentrators and are designed to optimize light 

collection and redirection. They play a crucial role in increasing the concentration ratios, which 

is particularly valuable in concentrated solar power (CSP) systems. 

 

Secondary concentrators come in various forms, including compound parabolic concentrators 

(CPCs) and tailored optical designs. These concentrators help capture and redirect sunlight that 

might otherwise escape or scatter, thereby increasing the overall concentration factor. This 

collaboration between primary and secondary concentrators is an effective strategy for 

maximizing the efficiency of solar energy systems. [3-4] 

 

 

2. RAY TRACING SIMULATIONS 

 

2.1 Basics of Ray Tracing: Ray tracing is a computational technique used to model the 

behavior of light rays as they interact with optical surfaces. It finds applications in diverse 

fields, including computer graphics, architectural design, and optics. In the context of solar 

concentrators, ray tracing is employed to simulate how sunlight interacts with the surfaces of 

the concentrator and how it is directed toward the target. 

Ray tracing is based on the principles of geometric optics, where light rays are traced as they 

propagate through the optical system. It simulates the path of individual rays, accounting for 

reflection, refraction, and absorption, among other optical phenomena. The resulting 

simulation provides insights into how the concentrator collects and concentrates sunlight, 

offering valuable data for analysis and optimization. 

 

2.2 Importance of Ray Tracing in Solar Concentrators: Ray tracing is a pivotal tool in the 

design, analysis, and optimization of solar concentrators. It allows engineers and researchers 

to create precise models and predict how different design parameters influence the 

concentrator's performance. This capability is essential for maximizing the efficiency of solar 

energy systems. 

Ray tracing simulations provide quantitative data on key performance metrics, including the 

concentration ratio, optical efficiency, and irradiance distribution. These metrics are critical for 

evaluating the effectiveness of a solar concentrator design. Ray tracing helps optimize the 

geometry, material properties, and other design parameters to achieve the desired performance 

goals. 

The importance of ray tracing in solar concentrators can be exemplified through real-world 

applications. For instance, in concentrated photovoltaic (CPV) systems, ray tracing simulations 

have been used to design and analyze concentrator geometries that achieve optical efficiencies 

ranging from 30% to over 40%. These high optical efficiencies are indicative of the precision 

and optimization enabled by ray tracing.[5] 
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2.3 Ray Tracing Software and Tools: A variety of software packages are commonly used for 

ray tracing simulations in the field of solar concentrators. These software tools provide user-

friendly interfaces that facilitate the creation, analysis, and optimization of concentrator 

designs. They serve as platforms for defining the geometry of the concentrator, simulating 

sunlight conditions, and evaluating performance metrics. 

Zemax, a well-known optical design software, offers robust ray tracing capabilities and has 

been applied in the design of concentrating photovoltaic (CPV) systems. TracePro is another 

widely used software tool that aids in modeling and optimizing the behavior of light in optical 

systems. These software packages have graphical interfaces that allow designers and engineers 

to visualize and fine-tune their concentrator designs.[6] 

 

3. DESIGN AND ANALYSIS USING RAY TRACING 

 

3.1 Initial Design Phase: The initial design phase of a hyperboloid solar concentrator involves 

determining critical parameters that influence its performance. These parameters include the 

focal length, aperture size, and the selection of materials for the concentrator's components. 

Ray tracing simulations play a valuable role in visualizing how these parameters affect the 

concentration of sunlight onto the target. 

Focal length is a key parameter in concentrator design. A longer focal length increases the 

distance from the vertex of the concentrator to the focal point, which can result in a higher 

concentration ratio. For example, a hyperboloid concentrator with a focal length of 2 meters 

may achieve a concentration ratio of 1000:1, indicating a significant increase in energy 

intensity. 

Aperture size is another crucial consideration. The size of the concentrator's opening 

determines the amount of sunlight that can be captured and concentrated. Designers use ray 

tracing to optimize the aperture size to balance between capturing as much sunlight as possible 

and maintaining high optical efficiency. 

The choice of materials for the concentrator's components is influenced by factors like optical 

properties and durability. Ray tracing can assist in assessing how different materials impact the 

concentrator's performance. For instance, the reflectivity and transmissivity of materials affect 

the overall optical efficiency of the concentrator. [7-9] 

 

3.2 Simulation Setup: Setting up ray tracing simulations involves defining the geometry of 

the concentrator and the conditions under which it will operate. This includes specifying the 

angle of incidence of sunlight, the solar irradiance, and the spectral characteristics of sunlight. 

By providing detailed input data, simulations can closely replicate real-world scenarios, 

delivering accurate performance predictions. 

Angle of incidence is a critical parameter in solar concentrator design. It determines the angle 

at which sunlight strikes the concentrator's surface. The efficiency of light capture and 

concentration depends on this angle. Precise simulation of various angles of incidence allows 

for a comprehensive analysis of the concentrator's performance under different sunlight 

conditions. 
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Solar irradiance data, often obtained from solar irradiance databases or measurements, provides 

information about the amount of solar energy available at a specific location. Accurate 

irradiance data is essential for simulating real-world conditions and evaluating the 

concentrator's performance in different geographic regions. 

The spectral characteristics of sunlight, including its wavelength distribution, influence the 

behavior of light as it interacts with optical materials. Ray tracing simulations can incorporate 

this data to analyze the concentrator's response to different parts of the solar spectrum. [10] 

 

3.3 Performance Metrics: Performance metrics are essential for evaluating the effectiveness 

of a hyperboloid solar concentrator. Several key metrics are commonly used: 

 

Optical Efficiency: Optical efficiency quantifies how effectively the concentrator collects and 

concentrates sunlight onto the target. It is calculated as the ratio of the power of concentrated 

light at the target to the incoming solar power. High optical efficiency indicates that a 

significant portion of the incoming sunlight is effectively captured and directed toward the 

focal point. 

 

Concentration Ratio: The concentration ratio measures how much the sunlight is intensified 

by the concentrator. It is typically expressed as the ratio of the incoming sunlight's irradiance 

to the irradiance at the target area. A high concentration ratio signifies that the concentrator 

successfully magnifies the intensity of sunlight, resulting in higher energy output. 

 

Irradiance Distribution: This metric assesses the distribution of concentrated sunlight on the 

target area. The uniformity and efficiency of energy collection are influenced by how evenly 

the concentrated light is distributed. Ray tracing simulations provide quantitative data 

regarding irradiance distribution, allowing for precise comparisons between different 

concentrator designs. 

For example, in a study of concentrated photovoltaic (CPV) systems, researchers achieved an 

optical efficiency of 38.6% and a concentration ratio of 1315 suns using a hybrid Fresnel lens-

based CPV system. These performance metrics demonstrate the potential of well-optimized 

concentrator designs in enhancing solar energy conversion. [11-13] 

 

3.4 Sensitivity Analysis: Ray tracing simulations enable sensitivity analysis, a vital process 

for understanding how small variations in design parameters can impact concentrator 

performance. Engineers can systematically adjust parameters such as the concentrator's shape, 

size, and material properties to assess their influence on metrics like concentration ratio and 

optical efficiency. This analysis is instrumental for fine-tuning and optimizing the 

concentrator's design. 

For example, sensitivity analysis can reveal how minor changes in the focal length of a 

hyperboloid concentrator affect its performance. Even small variations can result in noticeable 

differences in the concentration ratio and optical efficiency. Understanding these sensitivities 

helps designers make informed decisions during the optimization process. 
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3.5 Optimization Techniques: Engineers and researchers use ray tracing simulations to 

explore a variety of optimization techniques. These techniques aim to enhance the efficiency 

of the concentrator and maximize its capacity to concentrate sunlight onto the target. The 

optimization process often involves iterative design refinements based on insights gained from 

ray tracing simulations. 

Optimization may encompass adjustments to the shape, dimensions, and materials of the 

concentrator. The goal is to achieve the desired performance metrics, such as a high 

concentration ratio and optical efficiency. For instance, by systematically modifying the 

geometry of a hyperboloid solar concentrator, designers can improve its ability to capture and 

focus sunlight effectively. 

The iterative nature of the optimization process is well-suited to ray tracing simulations. 

Designers can evaluate the impact of design changes on performance metrics and refine their 

designs accordingly. This approach allows for the development of highly efficient 

concentrators. 

 

3.6 Tolerance Analysis: Tolerance analysis is a critical aspect of concentrator design, as it 

assesses how manufacturing imperfections or variations can affect concentrator performance 

in real-world applications. Ray tracing simulations are employed to identify potential issues 

and develop strategies to mitigate the impact of manufacturing tolerances. 

Manufacturing tolerances encompass variations in dimensions, material properties, and optical 

surface quality. These variations can arise during the production of concentrator components. 

Tolerance analysis helps ensure that even with manufacturing imperfections, the concentrator 

continues to meet its performance targets. 

For instance, in a tolerance analysis of a solar concentrator, ray tracing simulations can assess 

how variations in the curvature of optical surfaces or the alignment of components affect 

optical efficiency and concentration. Designers can then implement design features or 

tolerancing strategies to minimize the impact of manufacturing tolerances and maintain 

performance. [14-16] 

 

4.  GEOMETRICAL MODELLING OF ELLIPTICAL HYPERBOLOID 

SOLAR CONCENTRATOR 

The design of the Elliptical Hyperboloid Model geometry concentrator is based on three main 

geometrical parameters. Out of all three the first parameter is an elliptical entry aperture that 

directs the solar radiation to enter into the concentrator. In order to capture the maximum 

collection of light rays, the length of the elliptical major axis related to the elliptical entry 

aperture needs to be optimized based on the acceptance angle of the geometry. The second 

parameter is an elliptical exit, which deviates from the conventional solar concentrator. The 

third parameter is a hyperboloid profile slides, which connects the elliptical entry aperture and 

elliptical exit. Based on these three parameters, the configuration of the geometry is named as 

Elliptical Hyperboloid Concentrator. The joining of the ‘elliptical entry aperture’ and ‘elliptical 

exit receiver’ by a hyperboloid profile generates a smooth geometry. The generated geometry 

is an innovative design, which has not been examined or studied by researchers in the literature 

as per the author’s knowledge.  
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The idea of creating smooth elliptical hyperboloid concentrator geometry shows a lot of 

strengths. In the literature review, it was found that the hyperbolic profile in non-imaging 

concentrators shows improved performance in acceptance angle and energy collection. It was 

also stated that the solar concentrator based on the hyperboloid revolution has the ability of 

concentrating all the incoming solar rays. 

 

 

Here is a detailed procedure for drawing circular and elliptical hyperboloid model using CATIA 

drafting software: 

 

 

1. Launch CATIA and create a new part file. 

2. Create the receiver base: Select the "Sketcher" workbench and use the "Circle" for circular 

hyperboloid model and "Ellipse" tool for elliptical hyperboloid model to draw circle and ellipse 

with the desired major and minor axes. You can specify the dimensions of the ellipse using the 

"Dimension" tool. 

3. Create the hyperboloid: Select the "Generative Shape Design" workbench and use the "Sweep" 

tool to create the hyperboloid. Select the base circle and ellipse as the profile to sweep and 

draw a line or curve to use as the path. Set the sweep parameters to create the desired 

hyperboloid shape. 

4. Add any additional features: Use other tools and features to add any additional details or 

features to the model, such as fillets, chamfers, or cutouts. 

5. Switch to the "Drafting" workbench: Select the "Drafting" workbench to create the drawing 

view of the hyperboloid model. 

6. Create a new drawing: Create a new drawing by selecting "File" > "New" > "Drawing." 

7. Insert the view: Insert the hyperboloid model view onto the drawing by selecting "Insert" > 

"Existing Component" > "From CATPart." 

8. Define the view: Define the view by selecting "View" > "Properties." Specify the scale, 

orientation, and visibility of the view as needed. 

9. Add dimensions: Add dimensions to the drawing by selecting the "Dimension" tool and 

selecting the appropriate points or edges on the hyperboloid model. 

10. Add annotations: Add annotations to the drawing by selecting the "Annotation" tool and 

specifying the text or symbols to include. 

11. Save the drawing: Save the drawing file for future use or export it to other software for further 

analysis or simulation. 
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Fig 1. 2D Hyperboloid Concentrator                             Fig 2. 3D Hyperboloid Concentrator 

 

(For circular hyperboloid model, circle drawn using the major radius) 

(For elliptical hyperboloid model, ellipse drawn using the major radius and minor radius) 

 

 

5.  RAY TRACING PROCEDURE IN TRACE PRO SIMULATION 

MODULE 

Ray tracing and flux distributions were investigated for different solar incidence angle by 

varying the system parameters such as concentrator height, receiver diameters and 

concentration ratio. 

Here are the stepwise commands for performing ray tracing of an circular and elliptical 

hyperboloid model in Trace Pro: 

1. Create a new project or open an existing one: Launch TracePro and create a new project by 

selecting File > New Project, or open an existing project by selecting File > Open. 

2. Set up the optical system: Use the Component Editor to add a Circular and Elliptical 

Hyperboloid component to the optical system. Specify the material properties, geometry, and 

orientation of the component. 

3. Define the light source: Use the Source Editor to add a light source to the system, such as a 

point source, a uniform source, or a custom source with a user-defined spectrum. Specify the 

position, direction, and polarization of the light. 

4. Configure the ray tracing settings: Use the Ray Trace Setup dialog box to set up the ray tracing 

settings by specifying the number of rays to trace, the convergence criteria, and the trace type 

(e.g., sequential or non-sequential). 

5. Trace the rays: Run the ray tracing simulation by selecting the "Trace Rays" command from 

the Ray Trace Setup dialog box, or by selecting Trace > Trace Rays from the main menu. The 

software will propagate the rays through the optical system and calculate their paths and 

properties. 
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6. Analyze the results: Once the simulation is complete, analyze the results by examining the 

output data using the Analysis Editor. View the irradiance, intensity, or polarization of the rays 

at various points in the system. Use this data to evaluate the performance of the system and 

identify any potential issues. 

7. Refine the design: Based on the results of the analysis, refine the design by adjusting the 

components or properties of the system. Repeat the ray tracing simulation to evaluate the 

impact of the changes. 

8. Generate reports: Generate reports to document the simulation results and design changes. Use 

the Report Editor to create custom reports that include tables, graphs, and images. Use the 

reports to communicate with team members or clients and to keep track of the design process. 

 

 
Fig 3. Ray Tracing Simulation Results Representing Absorbed power (Watts) 

 

Overall, the detailed procedure for performing ray tracing on circular and elliptical hyperboloid 

model using Trace Pro involves creating a 3D model, defining the light sources and sensor 

camera, and running the simulation to generate a realistic rendering of the object. 

 

 

6. CONCLUSION 

Solar energy is a cornerstone of sustainable power generation, and solar concentrators have 

emerged as a promising avenue for enhancing the efficiency and cost-effectiveness of 

harnessing this abundant resource. Among the diverse array of solar concentrator designs, 

hyperboloid concentrators have gained recognition for their unique geometric features that 

enable the precise focusing of sunlight onto a target. In this paper, we have delved into the 

operating principles of elliptical hyperboloid solar concentrators, elucidating their advantages 

and challenges. We have also highlighted the indispensable role of ray tracing simulations in 

the design, analysis, and optimization of these concentrators. 

Elliptical Hyperboloid concentrators, characterized by their elliptical hyperbolic shape, exploit 

principles of elliptical hyperbolic geometry to efficiently focus sunlight at a focal point. These 

concentrators come in two main types: primary concentrators that directly channel sunlight 

onto a target, and secondary concentrators that further intensify solar radiation by optimizing 

light collection and redirection. These devices hold great promise for applications ranging from 

concentrated solar power (CSP) systems to concentrated photovoltaic (CPV) setups. 

Ray tracing, a computational technique with broad applications, is central to the advancement 

of hyperboloid concentrator technology. By modeling the behavior of light rays as they interact 

with optical surfaces, ray tracing simulations enable precise predictions of how different design 

parameters influence concentrator performance.  
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As we have discussed, ray tracing provides quantitative data on essential metrics such as 

concentration ratio, optical efficiency, and irradiance distribution, serving as an invaluable tool 

for concentrator design. 

Numerous ray tracing software tools, such as Zemax and TracePro, offer user-friendly 

interfaces for creating, analyzing, and optimizing concentrator designs. Engineers and 

researchers rely on these tools to conduct sensitivity analyses that reveal how minor design 

variations impact performance, and to explore various optimization techniques. These 

simulations support decision-making during the initial design phase and help in addressing 

manufacturing imperfections through tolerance analysis. 

In conclusion, this paper underscores the pivotal role of ray tracing simulations in advancing 

the design and optimization of elliptical hyperboloid solar concentrators. These concentrators 

represent a dynamic and innovative solution in the quest for sustainable energy sources, and as 

we continue to explore new frontiers in renewable energy technology, ray tracing remains an 

indispensable tool, guiding the way toward more efficient, cost-effective, and sustainable solar 

energy generation. 
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